Working with imported files in SOLIDWORKS - Part 2

 

IN THE PREVIOUS ARTICLE related to working with imported files the main focus was in the functionality called "3D Interconnect". Now, in this article we want to get a bit more further in details and talk about the important things that should be noted when working with imported files in general.

 

You might have been wondering why sometimes you are not able to make a simple cut feature on the flat surface when it should be possible...

mceclip3.png

...or you might have been wondering why drawing views are not showing model edges when drawing view "Display style" has been set to "High Quality".

mceclip5.png

 

Of course there might be other reasons for such errors but when working with imported parts those errors are likely due to geometry topology errors that have been generated when SOLIDWORKS has processed surface data from imported file's (usually from STEP, IGES or Parasolid file) surface data that is stored as XYZ coordinates.

 

What are those errors and how can you find and fix them?

 

Sometimes those geometry topology errors can be seen clearly with bare eyes without zooming really close to geometry. Let's take the picture below as an example. On the right side of the picture there is a section view of the geometry. There it can be seen that the outer side radius is so big that it intersects with the inner side radius. This kind of geometry shape is inconsistent and impossible.

mceclip0.png

 

Each time when a non-SOLIDWORKS file is imported to SOLIDWORKS, it is recommended that the geometry is checked for such topology errors. The first thing that everyone should do is to make sure that settings "Automatically run Import Diagnostics (Healing)" and "Perform full entity check and repair errors" have been selected. These settings can be found from SOLIDWORKS settings: Tools > Options > System Options > Import > General.

mceclip1.png

 

Then when you open a non-SOLIDWORKS file, SOLIDWORKS prompts to run "Import Diagnostics" on this imported part. Please always press "Yes". It does not matter if you press "No". You can always launch "Import Diagnostics" command manually from "Evaluate" tab or via menu command "Tools > Evaluate > Import Diagnostics".

mceclip2.png

 

mceclip3.png

 

When "Import Diagnostics" PropertyManager command window opens, SOLIDWORKS analyses the geometry and if any faulty faces or gaps between faces are found, they are listed in the window. In the picture below there is an example of faulty faces. Actually the root cause for error seen in picture below is the same as the one that was mentioned a bit above in the text: outer side radius intersects with inner side radius, making the geometry inconsistent and impossible.

 

In the command window there is a button called "Attempt to Heal All" that can be used to fix the faulty faces. But it has to be remembered that there are a lot of situations where software cannot fix the faces. In these situations it is needed to repair the faces manually by using surface modelling tools

mceclip4.png

 

In the picture below you can see the result that we always want to see: geometry is correct and free of any faulty faces and gaps between faces. That means that you can move on with working with your imported file and no further actions are required.

mceclip7.png

 

What to do if "Import Diagnostics" command is inactive?

 

If "Import Diagnostics" command in "Evaluate" tab is inactive, it is because there are one or more additional features created in the feature tree. For example in the picture below you can see that "Import Diagnostics" command is inactive because there is one "Boss-Extrude" feature created in addition to existing Imported feature. In this situation it is not possible to fix the issue by suppressing the additional feature. 

mceclip1.png

 

In this situation the solution is to use the "Check" command that is found from "Evaluate" tab or via menu command "Tools > Evaluate > Check".

mceclip2.png

 

The benefit of using "Check" command is that the command is actually really fast to analyse the geometry, compared to using "Import Diagnostics" command. The difference in analysing time between these two commands can be clearly seen when working with models that contain a huge number of solid or surface bodies, for example hundreds or even thousands of bodies.

On the other hand,  unlike using "Import Diagnostics", "Check" command is missing the possibility to fix the faulty geometry.

"Check" command is perfect when you only want to verify if the geometry contains topology errors or not. In the picture below you can see the settings of "Check" command. The most often the best setup is to use option "Stringent solid/surface check" with all solids and surfaces to check all invalid faces and edges. When pressing the "Check" button, it usually takes only a second or two to run the check. So the command is really fast.

mceclip5.png

 

In the field "Result list" you can see the results of geometry check. On the left side of the picture below you can see the listed errors, which is always the result that we do not want to see. On the right side you can see that "Check" command has not found any errors and informed us with the message "No invalid edges/faces found". That message means that geometry is correct and free of any topology errors. That is always the result that we want to see. You can then move on with working with your imported file.

mceclip6.png

 

What if the errors are too difficult to fix or there is no time to fix the errors?

 

It is important and recommended to fix the faulty geometry but faulty geometry can also be left unfixed if the fixing would be too complicated or time-consuming. But then it has to be remembered that modifying the imported geometry might cause problems in downstream features. You might also experience issues with visibility of model edges of the imported geometry when working with drawings. These topology errors might actually prevent saving of drawings to *.DWG and *.DXF format because saving drawing to such formats will automatically convert drawing views to "High Quality" display style. Then model edges are not saved in the *.DWG or *.DXF file due to topology errors.

Sometimes topology errors are preventing SOLIDWORKS model to be exported to neutral formats, such as *.STEP file format.

 

To summarize all of this...

 

Working with imported files is not always easy. It just has to be remembered that different CAD systems use different modelling kernels and they are not working the same way. SOLIDWORKS has developed a magnificent technique for importing files coming from other CAD systems. This technique is described in this previous article related to working with imported files in SOLIDWORKS. But it is still a fact that you might face challenges when working with really complex geometries containing a huge number of surfaces. In these situations the faulty geometry needs to be located and corrected. Please also remember that you can always CONTACT PLM GROUP SUPPORT TO GET HELP.

 

 

 

 

 

Kas see artikkel oli abiks?
3 kasutajale 3st oli see abiks

Kommentaarid

0 comments

Palun logi sisse, et lisada kommentaar.